Ошибка open_basedir в Twitter Tools 2.4

Twitter Tools – прекрасный плагин для WordPress, позволяющий передавать твиты между twitter-сервером и блогом на WordPress. Плагин обладает множеством полезных функций, среди которых автоматическое создание заметок в блоге на основе твитов. Но после последнего обновления заметки вдруг перестали создаваться. Покопавшись в логах, выяснилось, что происходит конфликт с системой защиты в виде следующего события:

[sql]
[Wed Oct 6 15:14:06 2010] [error] PHP Warning: require_once()
[<a href=’function.require-once’>function.require-once</a>]: open_basedir restriction in effect.
File(twitteroauth.php) is not within the allowed path(s): (/home/myuser/) in
/home/myuser/htdoc/wp-content/plugins/twitter-tools/twitter-tools.php on line 1516
[/sql]

После небольших поисков в интернете нашлось локальное решение проблемы.

Файл: twitter-tools/twitter-tools.php строка 1516
[sql]
require_once(dirname (__FILE__) . ‘/twitteroauth.php’);
[/sql]

Файл: twitter-tools/twitteroauth.php строка 10
[sql]
require_once(dirname (__FILE__) . ‘/OAuth.php’);
[/sql]